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INTRODUCTION

What is a repeat? In pattern terms, a repeat is a piece of art or design that duplicates 
endlessly. As simple as this may sound, it takes a certain amount of knowledge and skill 
to create a successful repeatable design. You can greatly enhance your work by 
understanding the techniques and structure behind this process.

Before the use of computers, pattern creation was a painstaking process of drawing, 
copying and re-drawing. With the arrival of Adobe Photoshop and Illustrator, print        
creation has become much more streamlined. Small designers, large companies and 
printing factories all use this software, and thankfully can all agree that it is the most 
convenient for design and output to printers. For a surface designer, understanding this 
software is essential. 

There are many different types of repeats but we believe that if you understand the 
principle behind just a few, you’ll be able to master the others. In these tutorials, we’ll 
be taking you through the following types of prints: tosses, drop-steps, symmetricals, 
and stripes, as well as walking you through the process of color separation. We’ll 
explain each kind of repeat and show you how to create it using several different 
tools and tricks.  

These tutorials will demonstrate the basic steps in creating a repeat, and require that 
you have a certain level of understanding of Illustrator and Photoshop. Before you 
begin, you should be proficient in using the duplication, align, and move tools, as 
well as working in layers. Of course there are multiple ways to achieve the same thing 
in these programs, so use these guides as loosely as you want.

___________________

List of Basic Terms

Object/Design Element  A piece of art or design which is arranged to form a repeat.

Swatch  Another name for a repeatable piece of artwork. Illustrator also has a tool 
called Swatches.

Working Repeat  A swatch that repeats but is not a perfect square/rectangle. It is 
called a working repeat because elements can still be easily edited and altered.

Factory Repeat  A swatch that repeats and is built in a perfect square/rectangle. It 
is called a factory repeat because it is in the final form that a factory might need to 
begin the printing process.

Toss Repeat  A seamless random-seeming repeat type.

Grid Repeat  A structured-looking repeat based on a grid.

Symmetrical Repeat  A repeat whose artwork is mirrored creating symmetry.
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TUTORIAL 1: TOSS REPEAT

When you want to create a photograph-
ic or highly textured print, Photoshop 
is the program of choice. Although it 
lacks many of the helpful tricks which 
are found in Illustrator, it makes up for 
its ability to retain a hand-painted look. 
Here we show you how to create a seam-
less repeat in Photoshop.

Step One

Import or create your artwork in 
Photoshop.

Step Two

Duplicate your artwork to the right 
(hold down the shift key as you move 
the repeatable unit to make sure it is 
lined up exactly.) Now duplicate these 
two repeatable units and move to the 
top. Make sure to leave enough room 
between swatches so that you can fill in 
the space.  

Step Three

Choose one of the swatches as the one 
you’ll be developing and lock the others 
to avoid confusion. The locked layers 
are just placeholders. Remember, you’re 
always working on just the one swatch 
while the others remain as placeholders. 

Step Four

Fill in the blank areas of the swatch until 
it connects with the placeholders, using 
whatever method your prefer (copy and 
pasting or duplicating areas.)  

In this section, we will demonstrate techniques to create seamless repeats in Photoshop. You 
should be comfortable in this program before beginning these tutorials. Feel free to modify 
steps with keyboard shortcuts or use other methods that are more familiar to you. We will first 
start with demonstrating how to design a toss repeat because this is one of the most chal-
lenging types of patterns to create without a seam. If you can design a good toss, creating 
a stripe or a symmetrical repeat is quite easy.  
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Step Five

Unlock and delete the placeholder 
layers.

Step Six

Duplicate your swatch to make sure it 
repeats correctly. If the swatch repeats 
the way you like, then you’ve made 
your repeat work! Often, you’ll have to 
go back and forth multiple times until it 
looks right.  

Now all you have to do is fill in your 
document and you’re ready to go!

TUTORIAL 2: FROM WORKING REPEAT 
TO FACTORY REPEAT

Step One

To create a factory repeat, select the 
top part of your swatch. Make a copy 
of that portion of the design by holding 
down the option key and shift key while 
dragging it down to the bottom of the 
swatch. The shift key keeps the elements 
aligned as you move.
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Step Two

Repeat the step above but select the 
left side and move it to the right. You 
now have your factory repeat.  

Tip: You may want to leave a copy of the 
original working repeat as a layer with 
the visibility turned off. That way you can 
always go back to it if you want to make 
changes later on. Once your artwork is in 
factory repeat form, it is more difficult 
to edit. 

Step Three

Repeat your swatch to fill in the size of 
your document. You may want to merge 
the repeat layers to reduce file size. 

File Format Notes:
If selling a pattern to clients, you might 
want to have a separate layer or two 
that includes file information such as the 
print number or your logo, in addition to 
a border which helps create a finished 
look to your design. These layers should 
live at the top of your layers palette so 
if the design is printed, this information 
would appear.

Also, if your original artwork is in layers, 
keep that version available in your layers 
palette.  
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TUTORIAL 1: WORKING WITH SYMBOLS

Step One

Once you create your artwork, make 
sure you have your symbols palette 
visible. You can select it from the windows 
drop-down menu. 

Select all your artwork and make it a 
symbol by choosing New Symbol from 
the symbols palette drop-down menu. 
(You can also simply drag the artwork 
into the symbols palette.)

Step Two

Duplicate your symbols vertically and 
horizontally so there are now four instances of 
your symbol. Make sure they are aligned. 
Now, you can work on any of these 
instances as they all reference one sym-
bol. 

In the previous section you learned how to create a repeatable design using Photoshop. You 
can apply the same principle in Illustrator, working on one swatch until it is perfect. However, 
it often takes multiple rounds of edits, repeating elements over and over again before you 
get the swatch looking right. This can be bothersome and time consuming. Fortunately, 
Illustrator CS3 and subsequent versions have a very handy tool called Symbols that eliminates 
the trial and error method. The Symbols tool works especially well when creating more 
complex designs.

From the Adobe website:  A symbol is an art object that you can reuse in a document. For example, if you cre-
ate a symbol from a flower, you can then add instances of that symbol multiple times to your artwork without 
actually adding the complex art multiple times. Each symbol instance is linked to the symbol in the symbols 
panel or to a symbols library. Using symbols can save you time and greatly reduce file size.
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Step Three 

To start filling in your swatch, select one 
of your instances, and click edit symbol 
from the top control bar. This will bring 
you into what is called isolation mode 
on that one instance, where you can edit 
the symbol.

Step Four  

In isolation mode, begin to fill in the 
blank areas between symbols. Go back 
to your main stage by clicking the back 
button at the top left.

Step Five  

You many need to go back and forth, 
adding elements to each side of the 
repeat as you work different instances.

Note: Scaling can get confusing with the 
symbols method. If you want to scale 
your artwork, remember to do so in 
isolation mode.
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Step Six

Once you are satisfied with your repeat, 
fill your document with your symbol.  
You may need to do a little more tweak-
ing once you see final view. You can still 
tweak any of your symbol instances at 
this point without having to re-do the 
entire repeat. 

Congratulations! You now have a working 
repeat in Illustrator. This process can also 
be acheieved without symbols by simply 
working on one swatch and duplicating 
it over and over in a similar manner as 
shown in this tutorial. However, working 
with symbols can save you time which 
can be precious when you’re on a deadline.

Tips:  Make sure to zoom out occasionally to 
see if striping occurs or if any elements 
jump out more than you want them to.

TUTORIAL 2: FROM WORKING REPEAT 
TO FACTORY REPEAT

Step One

Turn the visibility off of the layer that 
contains your working repeat.  Make a 
new layer, and drag a copy of your working 
repeat into it.  
    
If working with a symbol, you need to 
break the symbol and make it into a 
group. While the symbol is selected, 
click Break Link in the symbols palette, 
then select from the menu Object > 
Group. Now you’ll have all your objects 
in a group. This is your working repeat.   

If you’re not working from a symbol, your 
artwork is already in the right format.

Note: Make sure all your artwork is 
grouped together (Select from the menu 
Object > Group.) This is very important 
for duplication and alignment.  
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Step Two

Hide the selections around your artwork.  
(View > Hide Edges) You’ll need this to 
see what you’re doing in the next few 
steps.

Step Three

Select your swatch, copy, and paste in 
place. (Edit > Paste in Front.)

Step Four

Now you will move the unit you just pasted, 
and you’ll be able to see numerically just 
how far you need to move it. (Object > 
Transform > Move)  A Move window will 
appear. Make sure that Preview is selected, 
and begin to try out some numbers in 
the horizontal window. My first try was 
5 inches but I could see it went too far. 
4 was too close, but 4.5 seemed to fit 
nicely. Make a note of the distance that 
works for you and hit OK.  

Step Five 

Repeat Step Four, but this time, move 
the pasted swatch to the left of the 
original by the same distance you used 
for the right. In my case it would be -4.5 
inches. 

Step Six

Now you’ll be copying and pasting all 
three of these swatches, but moving 
them vertically.

Use trial and error to figure out the best 
distance for your design. For my pattern, a 
6 inch move vertically works best. To 
move it below my starting swatches, I 
use -6 inches. Now do the same by copying, 
pasting and using the move tool.   
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Step Seven

Now you’ll need to add the background 
into the artwork. Create a rectangle 
that is composed of the dimensions you 
came up with earlier. In my case, I will 
use 4.5 inches horizontally and 6 inches 
vertically. Next, color the shape with the 
shade you’d like for your background.

Step Eight

Align the middle repeatable unit with 
the background. When you align the 
background rectangle with the artwork, 
make sure the artwork stays where it 
is. To do that, select the two objects to 
align them, and then click on the artwork 
group one more time. That tells Illustrator 
that you want to align to the object you 
just clicked.  Align the two from the center 
points, both horizontally and vertically.   

Step Nine

Send the background layer behind your 
artwork. 

Transform > Arrange > Send to Back
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Step Ten

Next, you’ll need to create a mask using 
the same dimensions of your background 
rectangle. Any art outside of the rectangle 
will be trimmed off while the pattern within 
the shape will be preserved.   

The easiest way to do this is by selecting 
your background shape, then copying and 
pasting it in front of everything. Make 
sure to color this front shape in a shade 
that does not exist within your document.

Select all and then create the mask. 
Object > Clipping Mask > Make

Step Eleven

With your masked artwork selected, go 
to the Pathfinder Palette (Menu > Window 
> Pathfinder) and choose the Crop tool. 
This is the fourth button over from the 
left on the bottom row. This tool will cut 
off the hidden portion of your design 
leaving a clean version of your visible 
swatch.

Voila! You now have your factory repeat! 
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TUTORIAL 3: CREATING REPEATS WITH 
SWATCHES

In textile terminology a swatch is a re-
peatable portion of a design. In Illustrator, 
the Swatch palette provides some useful 
and powerful tools for creating repeats. 
To demonstrate how this tool works, we’ll 
first use the factory repeat we made in 
the last tutorial. Following this example, 
we’ll show you how to create a repeat 
using the Swatch palette.  

PART ONE
Step One

Select your factory repeat swatch and 
drag it into the Swatch palette. Your 
repeat will now appear as a small swatch 
in the palette which you can select and 
use as a fill.

Step Two

Create a rectangle and while it is selected, 
click on the swatch you just dragged 
into the Swatch palette. This will fill the 
rectangle with the swatch. If there are 
any problems with the repeat, such as 
gaps or cut off objects, you’ll see that 
very clearly now.  

You can also drag the swatch out onto 
your main stage to edit. Then simply 
drag it back into the Swatch palette 
once you are finished to use it again as 
a fill.
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PART TWO
Step One

Create a rectangle. In this case, the size 
is 6 inches horizontal by 5 inches vertical. 
Make a note of your dimensions for future 
reference.

Step Two

Start creating your artwork and overlap 
it on two sides of the rectangle – one 
horizontal side and one vertical side. 

Step Three

Select the objects that overlap the top 
area. Copy, then Paste in Front. Open 
your Move palette.  

Object > Transform > Move

Move the objects 5 inches down or the 
size of your rectangle’s vertical side. 

Step Four

Repeat Step Three but this time, move 
your objects horizontally using the 
horizontal measurement of your shape.

Step Five

Now that you have your repeat points 
set, you should tweak the artwork 
around it until everything fits.

Note: You can still move the repeat 
points, but you must move them together, 
making sure they are perfectly aligned 
to one another. If you have an object in 
a corner, you must repeat it both vertically 
and horizontally. 
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Step Six

You can leave the swatch in this state, 
but you must indicate to Illustrator 
where the repeat begins and ends. To 
do so, place a rectangle with no fill or 
stroke behind all of your artwork. It must 
be the exact same size and position as 
your background shape.

Copy your background rectangle and 
paste it behind all of your artwork. While 
it’s still selected, make sure it has no fill 
or stroke.  

And now your swatch is complete!

Step Seven

Select everything and drag it into the 
Swatch palette.

Step Eight

Create a large rectangle and while it’s 
selected, click on the swatch you just 
added to the Swatch palette. Voila!  You 
now have swatch you can easily use as 
a fill.

If your repeat is seamless and looks 
good to you, then you’re done!  If not, 
keep tweaking your design.

To create a factory repeat from here, you 
simply have to cut off the parts of your 
design existing outside of the rectangle.  
Go back to Tutorial 2 for reference. 
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SECTION 3: COLOR SEPARATIONS

TUTORIAL 1: SIMPLE SEPARATIONS IN 
ILLUSTRATOR

Step One

Once you have your swatch, double-
click on the magic wand tool. This will 
bring up an option palette. Make sure 
the Fill Color box is checked, and set the 
tolerance to zero. 

Step Two

Select one of the colors with the magic 
wand tool.  Then,  Edit > Cut.

Create a new layer, and Edit > Paste in 
Place.

Step Three

Repeat this for each of the colors in your 
swatch, placing each one onto a separate 
layer. Keep your background color as 
the bottom layer with all other colors 
building up from it in layer order.

And you’re done! Now you can pick your 
Pantone colors and you can also name 
each layer to help the printer. 

At some point, you may need to prepare your file for silk-screen printing. This process 
involves separating each color in your design onto its own layer. At the factory each 
color layer will then be turned into its own screen and printed individually one on top 
of the other. Colors are very easy to separate when they are solid with no gradation. It 
gets more complicated when there are subtle shades to each color such as in a hand 
painted watercolor design. In the following tutorials, we’ll show you how to do a simple 
color separation in Illustrator, and a more complex one in Photoshop. In both cases, your art 
should already be in a factory repeat swatch.
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TUTORIAL 2: COMPLEX SEPARATIONS 
IN PHOTOSHOP

Step One

Create multiple duplicates of your original 
swatch in the layers palette. Each one 
will become a separate color. 

Step Two 

Lock one of your layers down and turn 
off visibility. You’ll want to keep this in 
case you need to come back to it. 

Step Three

Turn visibility off on all layers but one.  
Select the layer that is on, and go to 
Select > Color Range.

Once you’re in the Color Range box, 
check the invert option.  Select the eye-
dropper on the left. Fuzziness should be 
set at around 40.

Click on a color in the artwork.  To ex-
tend the range of the color, either hold 
down the shift key while selecting simi-
lar colors, or use the eye-dropper with 
the plus sign. Ultimately, whatever you 
select, will become one color.  

Hit OK when done.

Hand painted artwork often uses so many colors that achieving the effect through screen 
printing is impossible. If this is the case, digital or dye sublimation printing might be the best 
option. However, if you can keep your colors limited to ten or less, Photoshop allows you to 
separate more complex designs while maintaining a hand painted look.

If you have more than ten colors and you want to reduce your screens, one trick is to increase 
the contrast of your work (Image > Adjustments > Brightness/Contrast.)  This will take out 
some of the mid-tones that create gradations and give you an easier starting point. 
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Step Four

Because you checked Invert, everything 
except the color(s) you chose is now 
selected. Hit Delete or Edit > Cut.

 

Step Five

Repeat this process on each of your layers, 
choosing different colors for each layer. 
Layers will start to look like the samples 
on the right.  
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Step Six

Tweaking is necessary and might take 
up the bulk of your time.

If you’ve picked up more than one color 
per layer, you’ll want to recolor everything 
on that layer to be the same shade.

You may need to create more layers 
initially than you plan on using in order 
to achieve the look you want.  

Later, you might be able to merge some 
colors that have similar tones or hues 
into a single layer. 

When you’re done, you can pick pantone 
colors and name your layers with either 
the pantone number or a description of 
each color. 
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SECTION 4: REPEAT TYPES

Despite the visual randomness of a pattern, if 
you look closely there is an orderly structure 
used at its base. Below we review the basic 
types of repeats. Understanding these 
structural systems leaves you with endless 
possibilities. 

GRID

The simplest repeat structure is based 
on an obvious linear grid. Diamonds, 
ogees, circles, stripes, plaids, and sym-
metricals are often built in this manner 
with the shapes repeating top to bottom, 
left to right. This basic repeat appears 
frequently in Interiors as it can often be 
too structured for general apparel wear. 
However, you can find this classic repeat 
in menswear on pieces such as ties and 
button-down shirts. 

TOSS

The earlier tutorials showed you how to 
create toss repeats using various techniques. 
Appearing random, flowing, and seamless, 
this common repeat works well on apparel and 
many other surfaces. If you can master 
the toss, then all other repeats will come 
easily.  

DROP STEP

In a drop step, the swatch remains 
aligned vertically but as it repeats to the 
side it drops down a certain amount 
often times balanced between the motifs 
found to the left or right. This creates 
a step effect as the elements repeat. A 
drop step can be used when creating a 
grid or toss pattern. 
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Tutorial 1:  Drop Step in Illustrator

The technique of designing a drop step 
is nearly the same as designing a toss or 
a grid repeat. The only difference is that 
the “placeholder” swatches drop down 
a step while you’re filling in the repeat.

Step One

Create your repeatable elements. If using 
symbols, make it into a symbol. If not, 
make it into a group.

Duplicate and move the swatch to the 
right and down.  

Hints: The move tool might be helpful 
for moving objects.  Objects > Transform 
> Move

If duplicating by dragging, the Transform 
tool is helpful. Objects > Transform > 
Transform again

Step Two

If working in CS3 or higher and with 
symbols, switch to isolation mode and 
fill in the gaps.

Note: If you’re in CS2 or lower there is no 
isolation mode. In this case, lock all the 
groups except the one you’re working on. 

Step Three

If you’re working in symbols, go back to 
your main stage, and see how the repeat 
looks. 

If you’re not in symbols, unlock the 
locked groups and delete them. Re-work the 
repeat with your new filled in swatch. If the 
repeat looks right, then you’re done!

By no means do we cover every repeat variety as there are too many. However, by understanding 
the basic structure of a pattern, you have the knowledge to create any type of design. As a 
pattern’s complexity grows, so do the creative challenges. In the following tutorials, we show 
how to work with more difficult repeats. From here you can develop your own techniques 
and solutions for design issues that may arise in your own prints.
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Tutorial 2:  Symmetrical Repeat in Photoshop

A symmetrical repeat is extremely easy 
to do and creates many unexpected and 
interesting results. For these reasons, 
many designers over-use this type of 
repeat, making their collections appear 
unvaried. Although this type of repeat 
may be simple, it is important to watch 
out for faces or other objects that might 
appear where the artwork’s seams meet. 
These unexpected features can cause 
undesirable effects especially in apparel 
where repeats must flow in a body-
conscious manner. 

When choosing this type of repeat, make 
sure your design has enough detail and 
variety for visual interest.

Here is one way to create a symmetrical 
repeat with flow and variation from hand 
painted artwork.

Step One

Scan in your artwork and paste it into 
your document.  
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Step Two

Duplicate your design element and 
move it directly to the right. Then, flip it 
horizontally creating a mirrored effect. 
Edit > Transform > Flip Horizontal. This is 
now your repeatable swatch.

Step Three

Repeat your swatch to create a pat-
tern. We use the drop step technique 
to give the repeat some variance. We’ve 
now created a flowing print from some 
scratchy paint strokes.  

File Organization Tip:  Notice the layers 
palette in the example on the right.  There 
is a folder which contains the original art-
work in layers. But, we’ve also duplicated 
this folder and merged the layers within 
it to create a flattened final version of the 
design. Leave this new flat layer visible and 
hide the folder with the original art. It’s 
important to keep a copy of the layered 
design so you can always come back to it 
if need be. 
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Tutorial 3: Hand-drawn Interlocking Repeat 
in Illustrator 

There are many ways to create seamless 
interlocking repeats and the previous 
toss tutorials will work for most designs 
in this category. Interlocking patterns 
can also be based on a grid and if created on 
the computer, can be quite easy to turn 
into a swatch. However, hand-drawn or 
painted artwork adds a level of complexity 
to this process.

The following tutorial shows you how to 
leave every part of your design hand-
drawn and achieve a seamless interlocking 
repeat. The use of a printer and scanner 
are necessary for this exercise.

Step One

Scan in your artwork and open it in 
Illustrator.  

Step Two

Make sure your Control window is open 
(Window > Control.)  While your artwork 
is selected, go to the drop-down menu 
near Live Trace and select, One Color 
Logo. This will create a vector version of 
your artwork. 

Note: In earlier versions of Illustrator, 
Live Trace can be found under the Objects 
menu.
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Step Three

Duplicate your artwork across and down, 
making sure you’ll have enough room to 
fill in the empty spaces between your 
objects.

Step Four

Keep one of your objects black while 
making the other ones a lighter color.

Step Five

Print a version of your artwork as set up 
in the step above.

Step Six

Fill in the space surrounding your artwork 
connecting it to its duplicate on the 
side and bottom.
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Step Seven

After scanning and importing, use Live 
Trace to vectorize your artwork once 
again. If you choose the One Color setting 
again, Illustrator will not read the lighter 
areas that you used as your place-hold-
ers. Select Expand again.  

Step Eight

At this point, there are probably minor 
tweaks you’ll need to do. Turning your 
artwork into a symbol as you make 
changes will help save time. If you’re not 
using symbols, don’t forget to erase the 
non-tweaked swatches and re-configure 
your repeat with the newly adjusted version.  

...And you’re done! 
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Tutorial 4: Diagonal Stripe in Illustrator

Some stripes can be easy to repeat, 
especially vertical or horizontal ones 
created on the computer. But what 
do you do with a hand-drawn or hand-
painted stripe, let alone creating one 
that’s diagonal? These all pose their own 
challenges and in the following tutorial 
we’ll show you how to create a diagonal 
stripe as well as offer tips for dealing with 
the others. 

For hand-drawn stripes that you’ll repeat 
in Photoshop, try using a ruler as a 
guide when drawing or painting your lines. 
Once in Photoshop, you can then use 
the brush tool to complete the connections 
between repeated elements.

For hand-drawn stripes that you’ll repeat 
in Illustrator, use graph paper to keep 
your stripes lined up and even. Small 
tweaks will probably be necessary once 
you bring the artwork into the program.

 

Step One

Create a stripe design that is equal in 
both height and width and fits within a 
perfect square. A black stroke around 
the square is used as a guide. Remove it 
after you’ve created your design.
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Step Two

Turn your stripe square 90 degrees. 
We’ll use the diamond structure to create 
our repeat.

Step Three

Duplicate your diagonal square horizontally, 
so that the two squares barely touch at 
the corners.

Step Four

Duplicate the two squares again and 
move them down and to the side until 
they fit into the squares above.

Step Five

Continue duplicating your elements and 
a diagonal repeat will appear. This design 
should repeat side to side and top to 
bottom. To create a factory swatch 
from here, simply reference the steps 
described in the earlier tutorial.
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CONCLUSION

The world of pattern design is endless once you understand the basic principles to 
creating a repeat. We hope these tutorials have proved helpful, providing you with 
techniques which can be developed and honed on your own. As with all things, 
practice makes perfect so continue to explore and try new methods. This can release 
your creativity and push your design skills to another level.

If you have any tips you’d like to share or have a vexing problem that needs a solution, please 
visit our forum and share with the community.

We also welcome any feedback or comments on our blog, facebook page or twitter 
page.  

Happy Patterning!
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We would like to thank Bekah Hilleson, and 
all of the wonderful print contributors for 
their help and support of this endeavor. 
Also, a big thank you to the readers, 
without whom this project would not 
have happened.

Thank you!
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